Breaking because of long filenames

General questions about using FtpVC, ideas for new features, bug reports, and usage tips.
Post Reply
Rathje
New Member
Posts: 2
Joined: Fri Apr 23, 2010 6:27 am

Breaking because of long filenames

Post by Rathje »

Hi
I'm getting extremely frustrated about a problem I hope someone have experienced and solved.
Up until yesterday alle stubfiles constited of some extensions with the escape characters % and #. But now it suddenly adds the @ for directorynames adding a truely long path to the filename.
The consequense is that FtpVC breaks when checking in etc due to inability to update the truncated filenames.
Any ideas to what happened in my settings or what to do about it?
Best regards
Lars Rathje, Denmark

User avatar
psguru
Site Admin
Posts: 1902
Joined: Sat May 15, 2004 4:23 pm
Location: California
Contact:

Re: Breaking because of long filenames

Post by psguru »

@ escape character is used for check-out directory namess. I suppose you checked out into a long-named directory. Now, version 2.5a fixed the problem with long path names. Are you using it?
psguru
PrestoSoft

Rathje
New Member
Posts: 2
Joined: Fri Apr 23, 2010 6:27 am

Re: Breaking because of long filenames

Post by Rathje »

Yes, I'm using 2.5a and I also tried to redownload and reinstall to be sure.

I am having some long directory names, but the issue is that two days ago it didn't use the directory paths - it just used until the "#"-signs, like you see here on my remote server:
/boost/nysport.dk/ftpvc/robots.txt.stub.1278909072.3.Lars.04-22-2010#210#138#150
/boost/nysport.dk/ftpvc/robots.txt;1
/boost/nysport.dk/ftpvc/robots.txt;2

Now today, if I delete those files and do another checkout, it looks like this:
/boost/nysport.dk/ftpvc/robots.txt.stub.1278909072.2.Lars.04-24-2010#206#152#109.C@3@1Users@1Lars@1DOCUME@C1@1Website@1nysport@Adk
/boost/nysport.dk/ftpvc/robots.txt;1

I do have some with even longer paths where it always makes an error and says it can't rename the stub. But again the question is why did it at all change to use the "@"-signs. I want it to go back to the first use, so I can stay out of trouble.

Thanks
Lars

User avatar
psguru
Site Admin
Posts: 1902
Joined: Sat May 15, 2004 4:23 pm
Location: California
Contact:

Re: Breaking because of long filenames

Post by psguru »

Let me try and explain how the escape characters are used.

The first one (in project Options | Advanced, % by default) is used to escape user name (if necessary). In your case it's not, hence "Lars" is not escaped. The second escape character (#) is used to escape timestamps, and you can see it used in your examples. The third one (@) is used to escape check-out directory names.

Now let's look at your examples.

Code: Select all

/boost/nysport.dk/ftpvc/robots.txt.stub.1278909072.3.Lars.04-22-2010#210#138#150
This is a stub of a checked-in file (3 before the user name tells us this), and it was checked in on 04-22-2010, at 10:38:50

Code: Select all

/boost/nysport.dk/ftpvc/robots.txt.stub.1278909072.2.Lars.04-24-2010#206#152#109.C@3@1Users@1Lars@1DOCUME@C1@1Website@1nysport@Adk
This is a stub of a checked-out file (2 before the user name), and it was checked out on 04-24-2010, at 06:52:09, into directory C:\Users\Lars\DOCUME~1\Website\nysport.dk

Note that a short folder name use used (new in 2.5a) in order to avoid long path issues (when a path is longer than 260 characters, which Windows doesn't like).

So I'm not sure what exactly changed for you but from what I see stub names are generated correctly. Perhaps something changed at your FTP provider. Also, what is the exact error that you are getting?
psguru
PrestoSoft

Post Reply